Burp community forum

Embedded browser initialization failed

Dan | Last updated: May 28, 2019 03:58PM UTC

Hi I am having an issue with the Response/Render feature of the embedded browser. When I click on "Render" in the "Response" tab I receive the following message "Embedded browser initialization failed" I also ran the Embedded browser health check and I get the following messages. Checking Platform Support - Success Checking Browser Binaries - Success Creating embbeded browser documenation window - Error Aborting checks due to errors. java.io.EOFException Burp Pro v2.0.22beta Kali Linux with all updates as of 2019-05-28 I have also attempted to update the installation and this did not resolve the issue. Any ideas? Thanks Dan

Liam, PortSwigger Agent | Last updated: May 29, 2019 07:02AM UTC

Thanks for the info, Dan. We're hoping to release a workaround for this issue in the next update of Burp 2.×.

Rose, PortSwigger Agent | Last updated: May 31, 2019 10:07AM UTC

We expect this issue to have been fixed in the latest release: v2.0.24beta. Let us know if you're still experiencing issues.

Burp User | Last updated: Jun 18, 2019 09:37AM UTC

Issue still exists. OS: Kali Linux with latest updates Burp Suite: Pro v2.0.24beta "Creating embedded browser documentation window Error" "Aborting checks due to errors. java.io.EOFException"

PortSwigger Agent | Last updated: Jun 18, 2019 10:12AM UTC

Shubham - sorry to hear you're still having difficulty. Can you please email support@portswigger.net with your Diagnostics and Embedded browser health check - which are both on the Help menu.

Burp User | Last updated: Jul 01, 2019 01:42PM UTC

Hello, I've just updated to v2.1 and I'm having the same error as above. Could you advise? Thanks,

Rose, PortSwigger Agent | Last updated: Jul 02, 2019 01:12PM UTC

Pepita– sorry to hear you're still having difficulty. Can you please email support@portswigger.net with your Diagnostics and Embedded browser health check – which are both on the Help menu.

Burp User | Last updated: Jul 26, 2019 02:16PM UTC

I had the same problem (Debian Stretch all upadtes, Burp Pro 2.1.02), but I found a java debug log which said: [0726/153651.016897:FATAL:setuid_sandbox_host.cc(157)] The SUID sandbox helper b inary was found, but is not configured correctly. Rather than run without sandbo xing I'm aborting now. You need to make sure that /home/.../.BurpSuite/burpbrowser/0.122/lib/chrome-sandbox is owned by root and has mode 4755. I did the change and everything is working. Regards

Rose, PortSwigger Agent | Last updated: Jul 29, 2019 10:04AM UTC

Thanks, Louis. When running as root, the embedded browser sandbox is switched off. Another workaround for this is to Disable the embedded browser sandbox when running as a non-root user (User options > Display > HTML Rendering > Enable embedded browser sandbox). Our development team are looking into a fix for this.

Hannah, PortSwigger Agent | Last updated: Jul 29, 2019 10:11AM UTC

Naffchwan, what operating system are you using and what have you tried already?

Burp User | Last updated: Sep 13, 2019 08:05PM UTC

Still seeing this in 2.1.03 on Debian Buster. If I disable the browser sandbox (eek) the health check then fails at: "Unable to created headless browser." See same debug message as Louis above, although needing to grant root privilege in order to run a browser feels very wrong, now if you'd said send corrupt IP packets I'd have understood. Changing the ownership and permissions to those in the debug log and enabling the sandbox works. All tests pass. I can read the Help pages again.

Burp User | Last updated: Sep 16, 2019 05:58AM UTC

Running sudo sysctl -w kernel.unprivileged_userns_clone=1 fixed it for me.

Burp User | Last updated: Oct 09, 2019 07:34PM UTC

@Florian Thanks, that solved the problem for me too! I'm on Debian.

Burp User | Last updated: Nov 19, 2019 10:24PM UTC

I have tried all suggestions above and none has suceeded. Burp Version 2.1.04 Burp Browser Version 0.144

Burp User | Last updated: Nov 20, 2019 04:15PM UTC

sudo sysctl -w kernel.unprivileged_userns_clone=1 Fixed it for me on a Debian machine. Thanks a million!

Burp User | Last updated: Nov 23, 2019 02:03PM UTC

I would advise strongly against that kernel setting. Setting it is a global change that unnecessarily increases the attack surface of your system. Refer here: https://lwn.net/Articles/673597/ https://security.stackexchange.com/questions/209529/what-does-enabling-kernel-unprivileged-userns-clone-do The fix mentioned above the kernel setting about changing the perms on the 'chrome-sandbox' file worked for me. Commands ran: sudo chown root:root ~/.BurpSuite/burpbrowser/0.144/lib/chrome-sandbox sudo chmod 4755 ~/.BurpSuite/burpbrowser/0.144/lib/chrome-sandbox Currently running: Burp Community 2.1.04 Debian 4.9.189

Ben, PortSwigger Agent | Last updated: Nov 26, 2019 01:03PM UTC

Hi Jimmy, Thank you for the information.

Burp User | Last updated: Nov 28, 2019 03:19PM UTC

@Jimmy, I don't think setting the SUID bit on a browser binary makes you more secure than disabling Debian specific kernel patch...

You need to Log in to post a reply. Or register here, for free.