Burp Suite User Forum

Login to post

Cursor Not Accurate at Request/Response Editor

Satrya | Last updated: Oct 05, 2020 05:00PM UTC

Hello, i have a problem with my burp. After I installed the latest version, my cursor is not accurate. It happens at request/response editor. For example, when I try to edit a request on the repeater tab, then I click on a line, the cursor will point to a letter, and if I delete the letter, the letter after it is swept away. Anyone could help me with this problem ? Because I don't find any solutions at google, and this problem bother me so much. Thanks.

Uthman, PortSwigger Agent | Last updated: Oct 06, 2020 09:18AM UTC

Hi Satrya, Which OS do you have Burp installed on? Can you send screenshots or a screen recording of the issue to support@portswigger.net?

TT | Last updated: Jan 30, 2021 10:54AM UTC

Hey! I have the same problem as Satrya. Is there a solution?

Uthman, PortSwigger Agent | Last updated: Feb 01, 2021 09:03AM UTC

Which version of Burp are you using? Which OS do you have Burp installed on? Can you please share screenshots or a screen recording with support@portswigger.net?

Miriam | Last updated: Feb 02, 2021 12:28PM UTC

Same problem here. Im using Windows10 and burpsuite pro. Any solutions?

Uthman, PortSwigger Agent | Last updated: Feb 02, 2021 12:30PM UTC

Miriam, please send an email to support@portswigger.net with your diagnostics (Help > Diagnostics) and a screen recording of the issue so that we can assist you further. Can you all try reducing the scaling in your Windows Display options to 100% to see if the issue persists?

Miriam | Last updated: Feb 02, 2021 12:46PM UTC

Wow, something with the resolution was wrong in Windows, i change it and it works fine now. THANK YOU GUYS! Months with this problem, making me sad. Have a nice day :D

Uthman, PortSwigger Agent | Last updated: Feb 02, 2021 01:47PM UTC

Great! We have a bug in our development backlog to address this issue when scaling is set above 100%. This thread will be updated when the fix has been implemented.

Dharmveer | Last updated: Feb 10, 2021 07:41AM UTC

The problem is still with burp 2021.

Uthman, PortSwigger Agent | Last updated: Feb 10, 2021 09:44AM UTC

Thanks for reporting, Dharmveer. A fix has not been implemented yet but this thread will be updated when it has. Unfortunately, we still cannot provide an ETA.

Joe | Last updated: Jun 27, 2021 11:54PM UTC

I Have fixed this issue by changing the font size

Ashutosh | Last updated: Aug 05, 2021 03:34PM UTC

hi

Ashutosh | Last updated: Aug 05, 2021 03:34PM UTC

hi

Ashutosh | Last updated: Aug 05, 2021 03:34PM UTC

Here is the fix !! I wrote a blog on it check this out https://i-ama-beginner.blogspot.com/2021/08/cursor-error.html . This should help generally speaking :)

Sandro | Last updated: Aug 24, 2021 02:20PM UTC

Hi, i have the same issue with kali linux. Is there a fix?

Uthman, PortSwigger Agent | Last updated: Aug 24, 2021 03:42PM UTC

Hi, Can you try adding these JVM options to the vmoptions file in your installation directory? If you are running the JAR, add them as command-line parameters. We are still working on investigating this issue. 1: -Dsun.java2d.noddraw=true 2: -Dsun.java2d.d3d=false 3: -Dswing.useflipBufferStrategy=True 4: -Dsun.java2d.ddforcevram=true 5: -Dsun.java2d.ddblit=false 6. -Dsun.java2d.uiScale=1 Please try the options both individually and together. You may need to change the resolution settings in your system display settings to less than 125% too.

Falko | Last updated: Aug 31, 2021 07:51AM UTC

Hi, same issue here on Kali Linux (rolling, updates as of 31.08.2021) using a 32" 4k display. I've had the issue for several versions, currently using Burp a lot and this issue is hugely annoying. Only option that worked for me is the workaround mentioned by Joe above: I changed the font size for "HTTP message display" from "Courier 16pt" to "Courier 18pt" through User options -> Display. Now I can precisely select text and the selection content matches the visual indicator. Things I tried that didn't work: - Turned Kali HiDPI mode on/off, obviously changed size of surrounding desktop items such as menu bar, but did not fix select bug - Tried each of the above mentioned 6 options on its own via user.vmoptions file, as well as all of them together - The only option that has a visible effect is "sun.java2d.uiScale=1". Both on its own and combined with all the others it appears to disable scaling completely. The initial project selection box is tiny and all other burp menus are not scaled too, which makes them unusable on my display. However, the selection of text is working correctly.

Uthman, PortSwigger Agent | Last updated: Aug 31, 2021 09:18AM UTC

Hi Falko, Thanks for reporting this. Our developers are investigating it so we will update this thread when a fix has been implemented.

Liam, PortSwigger Agent | Last updated: Nov 02, 2021 10:38AM UTC

The highlighting issue should now be resolved. - https://portswigger.net/burp/releases#professional Please let us know if you need any further assistance.

Krishna | Last updated: Dec 02, 2021 05:25PM UTC

Same problem in 2021 version

Uthman, PortSwigger Agent | Last updated: Dec 03, 2021 08:58AM UTC

Hi Krishna,

Which version specifically? The fix was implemented in 2021.9 so this should be working if you are using 2021.9 or higher.

Can you please share the information below with support@portswigger.net?

  • A screen recording of the issue replicated
  • Diagnostics (Help > Diagnostics)

If you have any extensions enabled, please try replicating the issue both with and without extensions enabled.

Konstantin | Last updated: Jan 20, 2023 08:05AM UTC

Hi there, I have 150% scale for the screen in the OS settings, and this option worked for me:   > java -jar -Dsun.java2d.uiScale=1 burpsuite_pro_v2022.12.6.jar But it neccesary to increase font size in the Burp itself from default to ajust font and elements size.

You need to Log in to post a reply. Or register here, for free.