Burp Suite User Forum

Login to post

Could not start Burp: java.lang.ExceptionInInitializerError

Tony | Last updated: Oct 10, 2019 08:25PM UTC

When attempting to install burp for mac, the image mounts but when double clicking to install, it just wont install. Then attempted to use the JAR version and getting the error: Could not start Burp: java.lang.ExceptionInInitializerError Exception: java.lang.ClassCastException: class com.install4j.runtime.beans.actions.misc.LoadResponseFileAction cannot be cast to class com.install4j.api.screens.Screen (com.install4j.runtime.beans.actions.misc.LoadResponseFileAction and com.install4j.api.screens.Screen are in unnamed module of loader 'app') at com.install4j.runtime.installer.config.ScreenBeanConfig.setBean(ScreenBeanConfig.java:88) at com.install4j.runtime.installer.config.AbstractBeanConfig.finishBatch(AbstractBeanConfig.java:58) at com.install4j.runtime.installer.ContextImpl.registerScreens(ContextImpl.java:727) at com.install4j.runtime.installer.controller.Controller.start(Controller.java:83) at com.install4j.runtime.installer.Installer.runInProcess(Installer.java:57) at com.install4j.runtime.installer.Installer.main(Installer.java:45) at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.base/java.lang.reflect.Method.invoke(Method.java:566) at com.exe4j.runtime.LauncherEngine.launch(LauncherEngine.java:85) at com.install4j.runtime.launcher.MacLauncher.main(MacLauncher.java:53) System properties: gopherProxySet=false awt.toolkit=sun.lwawt.macosx.LWCToolkit java.specification.version=11 sun.cpu.isalist= sun.jnu.encoding=UTF-8 java.class.path=/Volumes/BurpSuiteCommunity/Burp Suite Community Edition Installer.app/Contents/Resources/app/i4jruntime.jar sun.awt.enableExtraMouseButtons=true java.vm.vendor=Oracle Corporation sun.arch.data.model=64 i4j.ownBundlePath=/Volumes/BurpSuiteCommunity/Burp Suite Community Edition Installer.app install4j.exeDir=/Volumes/BurpSuiteCommunity/ sun.font.fontmanager=sun.font.CFontManager java.vendor.url=http://java.oracle.com/ install4j.systemLanguage=en user.timezone=America/Los_Angeles os.name=Mac OS X java.vm.specification.version=11 sun.java.launcher=SUN_STANDARD user.country=US sun.boot.library.path=/private/var/folders/sc/r9yb03614n9_fzqb13v8k4t80000gn/T/F2BC127C-7910-40A4-991A-484B6E4656B2-16133-000047D6BAFE7226/jre.bundle/Contents/Home/lib sun.java.command=com.install4j.runtime.launcher.MacLauncher http.nonProxyHosts=local|*.local|169.254/16|*.169.254/16 jdk.debug=release sun.cpu.endian=little user.home=/Users/<user> user.language=en java.specification.vendor=Oracle Corporation java.version.date=2019-01-15 java.home=/private/var/folders/sc/r9yb03614n9_fzqb13v8k4t80000gn/T/F2BC127C-7910-40A4-991A-484B6E4656B2-16133-000047D6BAFE7226/jre.bundle/Contents/Home file.separator=/ java.vm.compressedOopsMode=Zero based line.separator= java.specification.name=Java Platform API Specification java.vm.specification.vendor=Oracle Corporation java.awt.graphicsenv=sun.awt.CGraphicsEnvironment exe4j.moduleName=/Volumes/BurpSuiteCommunity/Burp Suite Community Edition Installer.app sun.management.compiler=HotSpot 64-Bit Tiered Compilers ftp.nonProxyHosts=local|*.local|169.254/16|*.169.254/16 java.runtime.version=11.0.2+9 javax.xml.parsers.SAXParserFactory=com.sun.org.apache.xerces.internal.jaxp.SAXParserFactoryImpl user.name=<user> path.separator=: os.version=10.14.6 java.runtime.name=OpenJDK Runtime Environment file.encoding=UTF-8 sun.java2d.noddraw=true java.vm.name=OpenJDK 64-Bit Server VM java.vendor.version=18.9 i4j.jreBundle=/var/folders/sc/r9yb03614n9_fzqb13v8k4t80000gn/T/F2BC127C-7910-40A4-991A-484B6E4656B2-16133-000047D6BAFE7226/jre.bundle install4j.appDir=/Volumes/BurpSuiteCommunity/Burp Suite Community Edition Installer.app/Contents/Resources/ java.vendor.url.bug=http://bugreport.java.com/bugreport/ java.io.tmpdir=/var/folders/sc/r9yb03614n9_fzqb13v8k4t80000gn/T/ java.version=11.0.2 user.dir=/Volumes/BurpSuiteCommunity/Burp Suite Community Edition Installer.app/Contents/Resources/app os.arch=x86_64 java.vm.specification.name=Java Virtual Machine Specification java.awt.printerjob=sun.lwawt.macosx.CPrinterJob sun.os.patch.level=unknown java.library.path=/Users/<user>/Library/Java/Extensions:/Library/Java/Extensions:/Network/Library/Java/Extensions:/System/Library/Java/Extensions:/usr/lib/java:. java.vendor=Oracle Corporation java.vm.info=mixed mode java.vm.version=11.0.2+9 i4j.tarFile=/Volumes/BurpSuiteCommunity/Burp Suite Community Edition Installer.app/Contents/Resources/app/jre.tar.gz sun.io.unicode.encoding=UnicodeBig java.class.version=55.0 socksNonProxyHosts=local|*.local|169.254/16|*.169.254/16

Ben, PortSwigger Agent | Last updated: Oct 11, 2019 07:41AM UTC

Hi Tony, Thank you for your message. There are few things that we can check. Do you get a particular error message when trying to install Burp via the installer? Have you tried performing a right click (Control + click) on the Burp Suite Professional Installer (once the image is mounted) and then selecting Open from the resulting context menu? This should present an Open option in the resulting dialog allowing you to install Burp. What is the exact command that you are entering when you try and run Burp via the Jar file? If you enter the java -version command in a terminal what Java version is being referenced?

Ben, PortSwigger Agent | Last updated: Jan 23, 2020 10:49AM UTC

Hi Robin, How are you running the installer, are you simply double-clicking it? Is it mounting successfully and then exits when you try and run the actual Burp Suite Professional Installer.app file? For the JAR version, do you have access to another version of Java that you can use to try and run this against?

Burp User | Last updated: Jan 23, 2020 03:08PM UTC

I am facing the same issue now. Tried installing v2.1.07 on MacOS v10.14.6 -> Installer exits immediately Downloaded jar java -jar burpsuite_pro_v2.1.07.jar Could not start Burp: java.lang.ExceptionInInitializerError $ java -version openjdk version "11.0.2" 2019-01-15 OpenJDK Runtime Environment 18.9 (build 11.0.2+9) OpenJDK 64-Bit Server VM 18.9 (build 11.0.2+9, mixed mode)

Burp User | Last updated: Jan 27, 2020 08:51AM UTC

Hi Ben, yes i tried it by mounting the dmg and double-clicking. I tried running it both with java 13 and java 11. I tried it today again on a different work-environment (with the same Mac) and the installer worked this time. I actually remember now, that i had the same problems with my previous Macbook (starting burp suite when beeing at a certain Workspace). Burp Suite seems to be having a Problem starting, when connected to a Displaylink monitor (which I am using at the previously used workspace where the installer failed)

Burp User | Last updated: Jan 27, 2020 09:02AM UTC

I just found the log files the installer was writing, and it seems to be the same Problem, that Jim is having here: https://support.portswigger.net/customer/portal/questions/17691824-installation-on-mac-throws-java-error At least it is the same exception in the logs. If I disconnect the Displaylink monitor everything works as expected

Michelle, PortSwigger Agent | Last updated: Jan 27, 2020 11:24AM UTC

Thanks for letting us know, I'm glad that's working for you now. Please let us know if you need any further assistance.

Zulin | Last updated: Mar 31, 2020 07:50PM UTC

Hello, I have downloaded burp jar file and trying to use on windows 10 machines using java -jar -Xmx2G /path/to/burp.jar command. But it throws an error - "could-not-start-burp-java-lang-exceptionininitializererror"

Ben, PortSwigger Agent | Last updated: Apr 01, 2020 01:04PM UTC

Hi, Are you using a laptop with external monitors when you experience this issue?

Antek | Last updated: Apr 08, 2020 09:53AM UTC

Hi, I just run int the same issue. After system restart - OSX 10.15.4 (unplanned crash actually) I was not able to start Burp or Burp installer. I got the same error when starting from console: Could not start Burp: java.lang.ExceptionInInitializerError when starting from dock I got only a logo splash and then it disappeared. I have my macbook pro 15 (2018) connected to two external monitors (LG 32UD99-W) using USB-C.

Ben, PortSwigger Agent | Last updated: Apr 08, 2020 10:32AM UTC

Hi, Do you have the laptop lid closed when using your external monitors?

Antek | Last updated: Apr 08, 2020 11:05AM UTC

Hi, yes, laptop has its lid closed. I was using it like this for the lat few months and this is the first time I have this problem. Workaround is to disconnect external monitors, run burp and re-connect monitors...

Ben, PortSwigger Agent | Last updated: Apr 08, 2020 05:37PM UTC

Hi, This is not an issue we have been able to replicate here in order to determine the root cause (it appears to only occur when certain types of monitor are used) but we have had some users report that they were able to get round this issue by opening the laptop lid and restarting Burp.

You need to Log in to post a reply. Or register here, for free.