Burp Suite User Forum

Login to post

CORS failure

Gurpreet | Last updated: Sep 28, 2021 05:42PM UTC

I am using burpsuite professional at my work and testing the client web application. I am facing problem with burp v2021.8.3 which is failing coz of CORS failure. I am getting the response from application in proxy but few of the links with post and options request faileld the CORS.I am unable to test the application as login functionality is not working due to CORS failure. Application is running fine if i do not use Burpsuite with no CORS error

Gurpreet | Last updated: Sep 28, 2021 09:29PM UTC

Update---Uninstalled the Param Miner extender solved my problem. I double checked after installing the Parama Miner again and it started giving out the problem. Please check on your end @portswigger for Param Miner interference with CORS.

Uthman, PortSwigger Agent | Last updated: Sep 29, 2021 10:36AM UTC

Hamza | Last updated: Nov 20, 2022 06:38AM UTC

Facing same problem on burp suite community (latest) and professional versions and even removed the Param Miner and all other extensions but still the browser requests are working fine without burp proxy and with burp proxy, no response is received. Kindly help and provide comprehensive solution. Thanks

Ben, PortSwigger Agent | Last updated: Nov 21, 2022 11:07AM UTC

Hi Hamza, Are you able to provide some specific details of the issue that you are currently facing so that we can assist you further?

Hamza | Last updated: Nov 21, 2022 11:47AM UTC

Please note that When I send the request using browser it gets the response as expected as shown in attached screenshot https://s22.filetransfer.io/storage/download/TOJ5sxsmRPhV When I copy the request from the browser as curl then it also works as expected as shown in this screenshot https://s22.filetransfer.io/storage/download/mHRtl5b7iQ4U But when the request is proxied through burp suite it doesn't get the response, as shown in attached https://s22.filetransfer.io/storage/download/OLb8HqjHXkW0 https://s22.filetransfer.io/storage/download/0e61A6jpKXIK I am attaching the screenshot of response headers https://s22.filetransfer.io/storage/download/SjBkxpypgjgT Please let me know what other information is required from my side and where I am making mistake and what is the fix?

Ben, PortSwigger Agent | Last updated: Nov 22, 2022 08:25AM UTC

Hi Hamza, Apologies but I am having trouble issues accessing the screenshots from the links that you have provided. Are you able to email us at support@portswigger.net and attach them in the email so that we can take a further look at this for you?

You need to Log in to post a reply. Or register here, for free.