Burp Suite User Forum

Login to post

cant accurately modify anything

Sp3kt4r | Last updated: Oct 29, 2020 02:23AM UTC

For some reason, when I higlight text to modify, it always leaves one or two characters behind making it impossible to tamper data. Example: I try to change the html to xml Content-type: text/html I highlight the whole thing but the L is left behind, so when I modify it it just does something like Content-type: text/htxml and NO, I'm not hitting insert. Burp version burpsuite_pro_v2020.9.2.jar

Michelle, PortSwigger Agent | Last updated: Oct 29, 2020 01:24PM UTC

Hi Thanks for getting in touch to report this, so we can try to replicate the issue can you tell us a bit more about your setup, please? Are you making these modifications in the Repeater tab or when you intercept requests? What OS are you using? If you're using Windows do you have any custom scaling options set in the display settings? What font and size settings do you have configured under User Options -> Display -> HTTP Message Display?

Sp3kt4r | Last updated: Nov 01, 2020 03:01AM UTC

Hi, This is happening on all tabs, even when I try to copy and paste from the proxy history. Using windows 10, custom scaling 125% (but already tried in 100% and doing same thing). Font size used Courier New 11pt. java version "13.0.2" 2020-01-14.

Michelle, PortSwigger Agent | Last updated: Nov 02, 2020 12:37PM UTC

Do you see the same issue if you use the installed version of Burp or is you use Java version 14? If so, would you be happy to share a screen recording showing the issue (where the windows custom scaling is set to 100%) to help us try and replicate the issue? You can email the screen recording to support@portswigger.net.

csh | Last updated: Dec 22, 2020 12:30AM UTC

Current Version: Burpsuite Professional v2020.12.1 I Had the exact same issue for a while and turning off Windows Custom scaling fixed it. Thanks :)

You need to Log in to post a reply. Or register here, for free.