Burp Suite User Forum

Can't open Burp Suite -- "Error: A JNI error occured, please check your installation and try again"

Cloufish | Last updated: May 21, 2020 04:32PM UTC

Here I provide full output after I launching Burp Suite : Error: A JNI error has occurred, please check your installation and try again Exception in thread "main" java.lang.UnsupportedClassVersionError: burp/StartBurp has been compiled by a m e Java Runtime (class file version 53.0), this version of the Java Runtime only recognizes class file vers at java.lang.ClassLoader.defineClass1(Native Method) at java.lang.ClassLoader.defineClass(ClassLoader.java:757) at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142) at java.net.URLClassLoader.defineClass(URLClassLoader.java:468) at java.net.URLClassLoader.access$100(URLClassLoader.java:74) at java.net.URLClassLoader$1.run(URLClassLoader.java:369) at java.net.URLClassLoader$1.run(URLClassLoader.java:363) at java.security.AccessController.doPrivileged(Native Method) at java.net.URLClassLoader.findClass(URLClassLoader.java:362) at java.lang.ClassLoader.loadClass(ClassLoader.java:419) at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:352) at java.lang.ClassLoader.loadClass(ClassLoader.java:352) at sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:495) I'm using Arch Linux, and the error is occurring after Burp Suite update. Please Help :P

Ben, PortSwigger Agent | Last updated: May 21, 2020 05:02PM UTC

Hi, Can you clarify which version of Java you are trying to run Burp with?

Cloufish | Last updated: May 22, 2020 07:28AM UTC

openjdk version "1.8.0_242" OpenJDK Runtime Environment (build 1.8.0_242-b08) OpenJDK 64-Bit Server VM (build 25.242-b08, mixed mode)

Ben, PortSwigger Agent | Last updated: May 22, 2020 07:38AM UTC

Unfortunately, Burp, Version 2020.4.1 no longer supports using Java 8 so you would need to update your Java version in order for Burp to work. We have tested the latest version against OpenJDK 13.0.3 but versions 9 and above should work.

You need to Log in to post a reply. Or register here, for free.