Burp Suite User Forum

Login to post

Can't connect to https://www.dyson.com through burp but it works with https:///www.dyson.co.kr or other tld (.fr,...)

Julien | Last updated: Nov 16, 2020 02:18PM UTC

Hi, I have well configured burp suite to connect to https website using cacert. I am almost in default configuration everywhere in burp. My problem is : I can't connect to https://www.dyson.com but I can connect to https://www.dyson.fr or https://www.dyson.co.kr. With the command below using curl (and burp as proxy) I have the default burp suite pro page : $ curl -sk https://www.dyson.com/en -H 'Accept-Encoding: gzip, deflate, br' -H 'Accept-Language: fr,fr-FR;q=0.8,en-US;q=0.5,en;q=0.3' -H 'User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:82.0) Gecko/20100101 Firefox/82.0' --proxy http://127.0.0.1:8080 > <html><head><title>Burp Suite Professional</title> > <style type="text/css"> > body { background: #dedede; font-family: Arial, sans-serif; color: #404042; -webkit-font-smoothing: antialiased; } > #container { padding: 0 15px; margin: 10px auto; background... > [...] ... but without burp : $ curl -sk https://www.dyson.com/en -H 'Accept-Encoding: gzip, deflate, br' -H 'Accept-Language: fr,fr-FR;q=0.8,en-US;q=0.5,en;q=0.3' -H 'User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:82.0) Gecko/20100101 Firefox/82.0' | gunzip - > <!doctype html> > <html prefix="og: http://ogp.me/ns#" lang="en-US"> > <head> > > <link rel="dns-prefetch" href="//assets.adobedtm.com"/> > > [...] ... if I try using the same command using curl and burp as proxy BUT trying to connect to www.dyson.fr : $ curl -sk https://www.dyson.fr/fr -H 'Accept-Encoding: gzip, deflate, br' -H 'Accept-Language: fr,fr-FR;q=0.8,en-US;q=0.5,en;q=0.3' -H 'User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:82.0) Gecko/20100101 Firefox/82.0' --proxy http://127.0.0.1:8080 > <!doctype html> > <html prefix="og: http://ogp.me/ns#" lang="fr-FR"> > <head> > > <link rel="dns-prefetch" href="//assets.adobedtm.com"/> > > <link rel="dns-prefetch" href="//dyson-h.assetsadobe2.com"/> > [...] I need some help :) Thank you Best.

Ben, PortSwigger Agent | Last updated: Nov 17, 2020 09:54AM UTC

Hi Julien, If you enable HTTP/2 support in Burp, via the "Enable HTTP/2 (Experimental)" checkbox under Project options -> HTTP -> HTTP/2, does this allow you to connect to https://dyson.com/en successfully?

Julien | Last updated: Nov 18, 2020 10:28AM UTC

Hi, Yes, It works. Thank you. :)

You need to Log in to post a reply. Or register here, for free.