Burp Suite User Forum

Login to post

Can no longer intercept Iphone requests (Apps and browsers) : 403 remote host terminated the handshake

quoc | Last updated: Nov 03, 2022 02:41AM UTC

I started having this issue 4 days ago, before that i had no trouble intercept requests from my iPhone. Device: - Iphone X: with Full Trust CA enabled - Burpsuite install on both MacOS and Windows machine - Burpsuite Community Edition: lastest version Current status: - Burpsuite return Proxy Error: The client failed to negotiate a TLS connection to xxx:443 : Remote host terminated the handshake - After connect to proxy, my phone cant access any app as well as any browsers due to Timeout - I can still intercept request from Burpsuite build-in browser What i tried: - Installed Burpsuite to another machine, using another network: Same issue - Tried with another iPhone: Same issue - Re-installed Certification - Enabled/disabled TLS 1.3 If you need more information please let me know, thanks in advance.

Ben, PortSwigger Agent | Last updated: Nov 03, 2022 06:57PM UTC

Hi Quoc, I have just replied to the email that you have also sent us about this issue - it might be easier to stick to one method of communication so we will await your reply there.

quoc | Last updated: Nov 04, 2022 04:02AM UTC

Hi Ben, The issue have been resolved thank to your help. I really appreciate it

jesorad | Last updated: Feb 26, 2023 12:12AM UTC

Hello, could you tell me how you solved this problem? I encountered a similar problem.

Ben, PortSwigger Agent | Last updated: Feb 27, 2023 10:09AM UTC

Hi Jesorad, I have just replied directly to the forum post that you sent us about this so I will await your reply there.

You need to Log in to post a reply. Or register here, for free.