Burp Suite User Forum

Login to post

Cache Poisoning Lab bot problems

avokado | Last updated: Jan 13, 2022 02:37PM UTC

Hello! I now tried doing first two Cache Poisoning labs (they are great, thank you PS!). I can poison the cache, and I can trigger XSS via Cache Poisoning locally but the lab is not being marked as done. I tried even looking at solution (it is pretty similar to my approach) and it still works the same - I can XSS myself but not the bot apparently. Since this is happening in two different labs, can it be possible that the bot itself is somehow struggling? I dont have any cache busters so the poisoning should be "global". Also I can keeping the cache poisoned for multiple minutes. Thanks.

avokado | Last updated: Jan 13, 2022 03:40PM UTC

EDIT: The labs expired and I've tried again and everything works as expected.

Michelle, PortSwigger Agent | Last updated: Jan 13, 2022 03:58PM UTC

Thanks for the update!

You need to Log in to post a reply. Or register here, for free.