Burp Suite User Forum

Create new post

BurpSuite not running on Java version 8u45, had to downgrade to 7u75

WispyCrypto | Last updated: Apr 16, 2015 04:27PM UTC

Hi, I recently tried running BurpSuite (current version) and was unable to run it with Java 8u45. I downgraded Java to 7u75 and it worked again. Has anyone else seen this error? # A fatal error has been detected by the Java Runtime Environment: # # EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x73064580, pid=5952, tid=1480 # # JRE version: Java(TM) SE Runtime Environment (8.0_40-b25) (build 1.8.0_40-b25) # Java VM: Java HotSpot(TM) Client VM (25.40-b25 mixed mode windows-x86 ) # Problematic frame: # C [MSVCR80.dll+0x14580] # # Failed to write core dump. Minidumps are not enabled by default on client versions of Windows # --------------- S Y S T E M --------------- OS: Windows 7 , 64 bit Build 7601 (6.1.7601.18409) CPU:total 4 (2 cores per cpu, 2 threads per core) family 6 model 58 stepping 9, cmov, cx8, fxsr, mmx, sse, sse2, sse3, ssse3, sse4.1, sse4.2, popcnt, avx, aes, clmul, erms, ht, tsc, tscinvbit, tscinv Memory: 4k page, physical 4077916k(1778096k free), swap 8153976k(4617072k free) vm_info: Java HotSpot(TM) Client VM (25.40-b25) for windows-x86 JRE (1.8.0_40-b25), built on Feb 10 2015 21:08:16 by "java_re" with MS VC++ 10.0 (VS2010) time: Thu Apr 16 10:07:52 2015 elapsed time: 1 seconds (0d 0h 0m 1s) Thanks.

PortSwigger Agent | Last updated: Apr 20, 2015 08:37AM UTC

This looks like a native crash in the Java process itself. Things like this are sometimes caused by compatibility issues with the OS in a particular set up (e.g. a particular video driver). You could try reinstalling Java (or a different version or vendor). Reverting to Java 7 is a reasonable solution if that works - provided you aren't running Java in your browser, using Java 7 for a desktop program like Java shouldn't in itself present any security issues.

You must be an existing, logged-in customer to reply to a thread. Please email us for additional support.