Burp Suite User Forum

Login to post

burpsuite issues over VNC connection

Alan | Last updated: Dec 01, 2019 12:16AM UTC

Hello! I've run into a peculiar issue and wondering if anyone else has overcome it - when running burpsuite over my VNC connection (my primary access method) the burpsuite windows show up as pink and do not display content. However, if I console directly in (using ESXi) or use over an xrdp connection (I installed to troubleshoot, but interacts more slowly over my apache guacamole client) it works just fine. Any ideas on how to adjust to work over VNC? Distro: Debian 10 JRE: 11.0.5 from debian repo burpsuite v2.1.04 (from kali rolling repo) VNC server: tigervnc-standalone-server v1.9.0 VNC client: apache guacamole PS - I normally get the "burp has not been fully tested on this platform and you may expereince problems" in my terminal, but it works just fine if not in a VNC session! strange.

Ben, PortSwigger Agent | Last updated: Dec 02, 2019 09:21AM UTC

Hi, Is it just Burp that is not displaying correct over your VNC connection?

Burp User | Last updated: Dec 06, 2019 04:18PM UTC

Hi Ben, Yes - it's the only GUI app that seems to have a problem currently.

Mike, PortSwigger Agent | Last updated: Dec 09, 2019 08:26AM UTC

Alan, have you tried any other VNC client/servers when you have been troubleshooting?

June | Last updated: Jun 16, 2020 08:12PM UTC

Did you ever figure this out? I'm also having this issue.

Ben, PortSwigger Agent | Last updated: Jun 17, 2020 10:26AM UTC

Hi, Unfortunately, we were not able to replicate this issue. Do you have details of the VNC client that you are using so that we can take a further look?

June | Last updated: Jun 17, 2020 01:17PM UTC

Sure! I am using x11vnc version 0.9.16 as a vnc server and have tried with both KRDC Version 17.12.3 and TigerVNC Version 1.7.0 as the client. I'm actually running Kali in a docker image. The Dockerfile and entrypoint.sh are as below, in case that's helpful. Dockerfile: FROM kalilinux/kali:latest ARG KALI_DESKTOP=xfce RUN apt update && DEBIAN_FRONTEND='noninteractive' apt install -y \ iproute2 \ firefox-esr \ kali-desktop-xfce \ kali-tools-top10 \ && DEBIAN_FRONTEND='noninteractive' apt-get purge -y pm-utils xscreensaver* ENV DISPLAY :1 ENV KALI_DESKTOP ${KALI_DESKTOP} RUN apt-get install -y x11vnc xvfb \ && mkdir ~/.vnc \ && x11vnc -storepasswd 1234 ~/.vnc/passwd COPY entrypoint.sh /entrypoint.sh RUN chmod 744 entrypoint.sh ENTRYPOINT ["/entrypoint.sh"] entrypoint.sh: #!/bin/bash Xvfb :1 -screen 0 1600x900x16 & DISPLAY=:1.0 export DISPLAY startxfce4 & /usr/bin/x11vnc -display :1.0 -usepw -forever & wait -n

Ben, PortSwigger Agent | Last updated: Jun 19, 2020 07:39AM UTC

Hi, We will take a look and see if we can replicate this environment and the issue that you are observing. We will report back to this thread with any further news.

You need to Log in to post a reply. Or register here, for free.