Burp Suite User Forum

Login to post

Burpsuite Community v2021_7_1 Windows 10

Erkan | Last updated: Jul 18, 2021 02:01PM UTC

Hi, I downloaded burpsuite_community_windows-x64_v2021_7_1 file as jar and exe file on Windows 10. When I started to installation by exe file, half time of the progress bar the installation was stopped and nothing change. Then I tried to install via jar file it gave some kinds of errors. java8u291 java se development kit 16.0.1 ``` D:\>java -version java version "16.0.1" 2021-04-20 Java(TM) SE Runtime Environment (build 16.0.1+9-24) Java HotSpot(TM) 64-Bit Server VM (build 16.0.1+9-24, mixed mode, sharing) ``` ``` D:\>java -jar ./burpsuite_community_v2021.7.1.jar Error: A JNI error has occurred, please check your installation and try again Exception in thread "main" java.lang.UnsupportedClassVersionError: burp/StartBurp has been compiled by a more recent version of the Java Runtime (class file version 53.0), this version of the Java Runtime only recognizes class file versions up to 52.0 at java.lang.ClassLoader.defineClass1(Native Method) at java.lang.ClassLoader.defineClass(Unknown Source) at java.security.SecureClassLoader.defineClass(Unknown Source) at java.net.URLClassLoader.defineClass(Unknown Source) at java.net.URLClassLoader.access$100(Unknown Source) at java.net.URLClassLoader$1.run(Unknown Source) at java.net.URLClassLoader$1.run(Unknown Source) at java.security.AccessController.doPrivileged(Native Method) at java.net.URLClassLoader.findClass(Unknown Source) at java.lang.ClassLoader.loadClass(Unknown Source) at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source) at java.lang.ClassLoader.loadClass(Unknown Source) at sun.launcher.LauncherHelper.checkAndLoadMain(Unknown Source) ``` ``` D:\>java -Xmx4g -jar ./burpsuite_community_v2021.7.1.jar Invalid maximum heap size: -Xmx4g The specified size exceeds the maximum representable size. Error: Could not create the Java Virtual Machine. Error: A fatal exception has occurred. Program will exit. ``` I added C:\Program Files\Java\jdk-16.0.1\bin location as path in Environment Variables and JAVA_HOME and then I deleted C:\Program Files (x86)\Common Files\Oracle\Java\javapath and C:\Program Files\Common Files\Oracle\Java\javapath information in Environment Variables but nothing change. Finally, I run as in below but not installed ``` D:\>java -jar --illegal-access=permit ./burpsuite_community_v2021.7.1.jar ``` At this point, I don't want to use this solution so that how can I install?

Uthman, PortSwigger Agent | Last updated: Jul 19, 2021 11:20AM UTC

It looks like you are using Java 16 but this has not been tested with Burp yet. Can you try using OpenJDK 15.0.2? (https://jdk.java.net/archive/) In terms of the Windows installer stalling, that does not look like expected behavior so can you please email support@portswigger.net with screenshots and steps to replicate? How much RAM is available on your system?

Erkan | Last updated: Jul 20, 2021 09:40AM UTC

Hi Uthman, thank you for your reply. I have i7 10th gen, 32GB RAM, 512GB SSD and 1TB HDD. I installed openjdk-15.0.2 but nothing changed for installion steps for via jar or exe file. I wrote an email support@portswigger.net with screen shots. Is there anything to I can try for installation?

Uthman, PortSwigger Agent | Last updated: Jul 20, 2021 10:31AM UTC

Hi Erkan, We will follow this up with you via email. The screenshots should hopefully some more information on what the issue could be.

You need to Log in to post a reply. Or register here, for free.