Burp Suite User Forum

Login to post

Burp suite won't start at all with java 16, when trying to add extension

Irem | Last updated: May 05, 2021 10:27AM UTC

Hey I was trying to add a custom plugin to the Burp Suite Professional 2021.5 version. But when I run the Burp Suite from the command line to adding the plugin(BurpJDSer-https://github.com/khai-tran/BurpJDSer/tree/master/executables), I get this error message: To run Burp Suite using Java 16 or above, please supply the following JVM argument: --illegal-access=permit How can I fix this issue?

Irem | Last updated: May 05, 2021 10:52AM UTC

I fixed this issue(I gave as a parameter "--illegal-access=permit" in the running command.) but I still get error message like: Error: Could not find or load main class burp.StartBurp Caused by: java.lang.ClassNotFoundException: burp.StartBurp How can i fix this?

Hannah, PortSwigger Agent | Last updated: May 06, 2021 04:37PM UTC

Hi Could you provide your full command to start Burp?

You need to Log in to post a reply. Or register here, for free.