Burp Suite User Forum

Create new post

Burp's browser / Renderer is not working. How do I fix this?

Max | Last updated: Jun 06, 2024 02:43PM UTC

I ran a health check for Burp's Browser and I got the following error: Checking headless browser: Error Aborting checks due to errors. net.portswigger.browser.Zyg: No dev tools websocket output from local chromium process 8635 I am running Ubuntu 24.04 on a Lenovo laptop. Any help much appreciated. Side note: I have dual boot Kali Linux and Ubuntu, the render works on Kali Linux but not on Ubuntu

Hannah, PortSwigger Agent | Last updated: Jun 07, 2024 09:28AM UTC

Hi Are you using the JAR version of Burp on your Ubuntu machine or the Linux installer version? If you try launching Burp's browser directly from your installation directory, does it launch successfully or do you receive any errors? You can find the file path for this by checking your diagnostics information ("Help > Diagnostics" within Burp).

Jade | Last updated: Jun 17, 2024 04:14PM UTC

This issue is caused by Ubuntu 24.04's breaking kernel change that now restricts the use of unprivileged user namespaces. As a temporary fix, you can create an AppArmor profile for Burp Browser. I did this by adding the following content to `/etc/apparmor.d/burpbrowser` ``` # This profile allows everything and only exists to give the # application a name instead of having the label "unconfined" abi <abi/4.0>, include <tunables/global> profile burp-browser @{HOME}/.BurpSuitePro/burpbrowser/**/chrome flags=(unconfined) { userns, # Site-specific additions and overrides. See local/README for details. include if exists <local/chrome> } ``` Then running `sudo apparmor_parser -r /etc/apparmor.d/burpbrowser` The PortSwigger dev team will need to implement this to fix this for Ubuntu 24.04+ users. --- Related: - https://discourse.ubuntu.com/t/ubuntu-24-04-lts-noble-numbat-release-notes/39890#unprivileged-user-namespace-restrictions-15 - https://github.com/electron/electron/issues/41066

Hannah, PortSwigger Agent | Last updated: Jun 18, 2024 04:00PM UTC

Hi Thanks for posting these steps and references! We're looking into how we can improve the user experience around this issue. If there's anything else we can help with in the meantime, please let us know.

Artiom | Last updated: Jun 18, 2024 04:02PM UTC

I tried but it did not work. Any other options?

Artiom | Last updated: Jun 18, 2024 04:08PM UTC

OK, I fixed it. It turned out that on my VM, the Burp browser path was different from what you provided in the comment. Thanks!

John | Last updated: Jul 07, 2024 11:30AM UTC

Thanks from me also. I hit the same snag this week. Only change I had to make was to drop the '.' from the file path for my build.

You must be an existing, logged-in customer to reply to a thread. Please email us for additional support.