Burp Suite User Forum

Login to post

[Burp Proxy with Android] No connection to proxy from other device

Tom' | Last updated: Dec 12, 2017 04:41PM UTC

Hello, I've recently had this error pop up and I'm unable to fix it. I'm trying to intercept http traffic from my Android device with Burp, I have done this with the exact same setup a few days ago and it worked fine, however the phone now behaves as if Burp proxy weren't up, it shows me a standard "Misconfigured proxy/Proxy refused connection" error message whatever I do. I'm out of ideas as to what the cause could be: - I've checked that the IP address I enter in Android is the right one - I've selected "all interfaces" in burp - I've checked that my computer is indeed listening on all interfaces on the selected port (it is) - Both devices are connected to the same network - The AP is a home network, there's no reason for it to suddenly start blocking client-to-client requests when it worked a few days ago The ONLY change I can think of is that I recently moved from Java7 to Java8 on my computer, but surely that can't be causing the proxy to behave strangely. Is there any obvious cause for the bug that I could have missed? Regards,

PortSwigger Agent | Last updated: Dec 12, 2017 04:41PM UTC

Hi Tom, Thanks for getting in touch. The most common cause of issues like this is a firewall on the computer running Burp. First, check you've disabled that. Try using a different computer and connecting to the Burp proxy post via telnet. Another thing to try is running Wireshark on the same computer as Burp. Can you see the connection attempts from your phone? Please let us know if you need any further assistance.

Burp User | Last updated: Dec 12, 2017 05:05PM UTC

Hello, I don't have a firewall, and Wireshark can't see any of my mobile device's connection attempts. I'm starting to think that the network suddenly started disabling client-to-client connections for no reason... I'll be borrowing someone's hotspot to check.

Burp User | Last updated: Dec 12, 2017 05:15PM UTC

Hello again, After checking using someone else's hotspot, it appears that our home network simply started blocking client-to-client communication between a few days ago and now. The "why" remains a mystery but what can you do. Thank you for your quick support, you've been very efficient and helped me rule out burp as the source of the problem very quickly. Tom

azri | Last updated: Jun 23, 2021 08:51AM UTC

Thank you..!!! I do it again and again but still got error. all solved once I turn off the pc firewall!!! . just search firewall on your PC and disabled it..

Majlinda | Last updated: Mar 08, 2023 01:18PM UTC

Hi, To anyone who is having the issue on March 2023, I tried all and everything found online, but nothing worked! I downgraded from API 29 to 28, and it came up automatically. Best, L

You need to Log in to post a reply. Or register here, for free.