Burp Suite User Forum

Login to post

[Burp Professional v2021.3.3] Filter setting is not working right after relaunching Burp.

KAISE | Last updated: Apr 15, 2021 06:59AM UTC

Hi. I'm using burp Professional v2021.3.3. I report a bug issue about the filter setting. Procedure is bellow: 1. Luanch Burp. 2. [Target > scope] Add a target URL. 3. [Proxy > HTTP proxy > filter setting] Turn on to "Show only in-scope items" to enable. 4. Apply and Re-enable "Logging of out-of-scope Proxy traffic is disabled" 5. Close Burp. (and save a Burp file) 6. Launch the Burp and load a saved Burp file. 7. [Proxy > HTTP proxy > filter setting] Check "Show only in-scope items" is enable. 8. Re-enable "Logging of out-of-scope Proxy traffic is disabled" 9. Access to out-of-scope URL. 10. Logging and showing in HTTP Proxy. ("Show only in-scope items" is not working) Thanks, KAISE

Uthman, PortSwigger Agent | Last updated: Apr 15, 2021 03:35PM UTC

Hi KAISE, Thanks for reporting this. We are looking into it and will get in touch if we need any more information. We will update this thread when the issue has been fixed too.

Michelle, PortSwigger Agent | Last updated: Apr 23, 2021 11:48AM UTC

Hi A fix for the issues with the filter on Proxy History has been included in the latest version of Burp (version 2021.4.2) released yesterday.

You need to Log in to post a reply. Or register here, for free.