Burp Suite User Forum

Login to post

Burp Pro Crashes Immediately Upon Start

Ken | Last updated: Feb 24, 2016 11:25PM UTC

java version "1.8.0_73" Java(TM) SE Runtime Environment (build 1.8.0_73-b02) Java HotSpot(TM) Client VM (build 25.73-b02, mixed mode, sharing) Latest version of Burp Pro. Upon launch, splash screen displays briefly and disappears but the java process is still running. Have tried several versions of Java and several versions of Burp Pro with the same results. Anyone else experience this issue? Where to begin with troubleshooting?

Burp User | Last updated: Feb 25, 2016 02:12AM UTC

Additional information: Thinkpad W541, core i7, 32GB RAM Tried safe mode, behavior still exists. Originally got this error: java.util.prefs.WindowsPreferences <init> WARNING: Could not open/create prefs root node Software\JavaSoft\Prefs at root 0x80000002. Windows RegCreateKeyEx(...) returned error code 5. Went to HKEY_LOCAL_MACHINE\Software\JavaSoft and created a Prefs key. No luck.

PortSwigger Agent | Last updated: Feb 25, 2016 11:28AM UTC

Please can you try adding --use-defaults to the Burp command line and see if that helps? The message about registry keys can be safely ignored.

PortSwigger Agent | Last updated: Feb 25, 2016 02:30PM UTC

Thanks for the update. Have you previously had Burp working correctly on this machine? So has a recent change to something introduced this problem or is this the first time you've tried to use Burp on this machine? Also, if you add --diagnostics to your command, do you see some output, and if so could you post it here or email it to us? Thanks.

Burp User | Last updated: Feb 25, 2016 02:52PM UTC

Should've mentioned that I had tried --use-defaults. Same behavior...quick splash screen and it dies but the java process is still resident.

Burp User | Last updated: Feb 25, 2016 04:23PM UTC

This is a brand new Win7 laptop. First time attempting to use Burp on this machine. Adding --diagnostics produces no output, just a quick splash screen and Burp dies.

PortSwigger Agent | Last updated: Feb 25, 2016 04:37PM UTC

Thanks for the update. It's possible that something is amiss with the Java installation on this machine. Please can you try installing Java again? If that doesn't help, maybe also try a different Java version.

Burp User | Last updated: Feb 26, 2016 02:45PM UTC

Have installed & uninstalled Java several times, using several versions. This is the only Java app that doesn't work. Have confirmed that all other Java apps work on this box.

PortSwigger Agent | Last updated: Feb 26, 2016 02:47PM UTC

All we can think of is to download Burp again from our server, and even verify the checksum against the release notes. We test Burp extensively on different OS and Java combinations, and aren't seeing this issue. It might also be worth absolutely double-checking that you have installed the correct version of Java for your OS, and that it is a full headed JRE, not a headless server version.

Burp User | Last updated: Mar 02, 2016 04:15PM UTC

Any other suggestions?

Burp User | Last updated: Mar 05, 2016 11:43PM UTC

Update: Loaded new laptop with Win10, still displays same behavior. Reloaded Win 7, still displays same behavior. Burp will not load/run on Win 7 or Win 10 on this hardware using several versions of JRE (1.6 up to latest version). However, all other Java apps work (e.g. Paros, etc.). Burp WILL run in a VM (Win 7 & 10) on this hardware. Any chance a dump file would be useful?

Burp User | Last updated: Mar 05, 2016 11:59PM UTC

Also, would the "-verbose" option in java help? I see a lot of exceptions when running java -verbose -jar \path\to\burp

Burp User | Last updated: Mar 06, 2016 12:31AM UTC

SOLVED: Burp will not run if a directory within the path ends with an "!". Burp was here: c:\!tools!\burp\burpsuite_pro_v1.6.38.jar. Moved the "burp" dir to the root directory and it runs fine. Tested by renaming the "burp" dir to "burp!" and burp crashes/will not run. Have not tried any other chars, just "!".

PortSwigger Agent | Last updated: Mar 10, 2016 10:14AM UTC

Thanks for letting us know, and glad you got things working. This sounds like it might be a Java issue.

Burp User | Last updated: Nov 17, 2016 05:45PM UTC

I have the exact same issue. But in my case, Burp is not located in a directory starting with "!". I have no idea what is happening.

Burp User | Last updated: Dec 14, 2017 10:19AM UTC

I was having the same issue. I found it was resolved by running it from an administrator cmd window

Jerome | Last updated: Nov 18, 2021 11:27AM UTC

WARNING! (although it may be too late by the time you scroll down here!) I was troubleshooting Burp freezing at start-up and came across this post. Tried the --use-defaults --diagnostics mentioned by support agent - but what's missing is a warning that --use-defaults isn't temporary. When I removed the argument later, I didn't get my previous settings back. BApps/user options gone. Unfortunately my last save was a while ago. I wonder if a warning should accompany this option, PortSwigger, and the help could be more explicit...? --use-defaults Start with default settings Unless it is _supposed_ to be temporary and this is a bug? Burp version 2021.9.1. Grateful if you could confirm expected behaviour.

Michelle, PortSwigger Agent | Last updated: Nov 18, 2021 03:00PM UTC

Thanks for getting in touch. Sorry about that, this is the intended behavior for --user-defaults, we'll see about making that clearer in the documentation. Thanks for bringing it up :)

You need to Log in to post a reply. Or register here, for free.