Burp Suite User Forum

Login to post

Burp Pro 2020.9.2 Freezes up entire VM

Jonathan | Last updated: Nov 03, 2020 12:20PM UTC

Howdy folks. Apologies for the long post but i want to be sure I cover all bases. I am posting here as I have been unable to find any posts online about this same topic. Burp Pro 2020.9.2 freezes up my entire VM(s) from time to time and makes it pretty painful to work sometimes. I absolutely love the product and my colleagues at work all use it as well but all have the same problem. We have macbook Pros as our workstations, various models. Some details: I have a 2017 15 inch, my colleagues have newer models. We all have 16gb of RAM, all retina Macs. These macs and kali/parrot have issues with Hi DPI so we lower the resolution of our macs using an app called easyres. Burp freezes with our without fixing the hi-dpi. We all can run burp on our macs just fine, but when we need to run it inside of any linux VM, Burp will sometimes freeze in the middle of our work and we have to forcefully shutdown the VM completely in order to regain control. We tried saving our burp projects to a file and sometimes it works but the VM freezes usually before it has time to auto save so we lose our place and have to spin it up all over again. We have tried various VM configurations (though it is all in virtualbox because we cant use VMware on these workstations per policy). We use latest version of Vbox, and we started off with Kali Linux. Everything works fine at first, we spin up burp and get to work. We almost never use the automated scanners but i imagine it would freeze just the same. It will freeze wether we're proxying requests nd inspecting manually, working in repeater, intruder, anything. It happens randomly. The entire VM will just freeze and we cant click on anything. You can sometimes mouse over stuff and you can see the little indentation happen on items in the taskbar but can never actually click on anything. Sometimes turning off mouse integration in Vbox at this exact moment helps, but my god is it hard to use the mouse. Then at some point it just freezes completely. At that point we said hey, lets give Parrot OS a go. Same thing. Then we switched to just straight up Ubuntu 20.04, then Latest Debian. It always happens on a linux VM. We have not tried using burp pro on a windows VM. We all have given our VMs 2, 4, 6, 8 GB of ram. We use the defaults from the Vbox importable OVAs for our VMs. We have tried setting things up manually and playing with configs. We nee to be able to use our VMs in order to work :( I am surprised no one in the community has these issues, i have not seen them reported anywhere. I have 4 or 5 colleagues, all with these same issues. Please help :)

Jonathan | Last updated: Nov 03, 2020 12:21PM UTC

I also want to add this has been an issue with every latest version of Burp pro for a year and a half

Uthman, PortSwigger Agent | Last updated: Nov 03, 2020 01:21PM UTC

Hi Jonathan, Thanks a lot for reporting this. VirtualBox is generally quite buggy. You mentioned that the entire VM freezes and not just Burp. Do you have any other resource-intensive applications running on the VM? If possible, can you find out the exact steps to replicate this issue and send us an email at support@portswigger.net? (Diagnostics would be helpful too) Have you tried increasing the number of virtual CPU cores available to your VM? Does your issue persist with the platform installer and the Burp JAR? Have you tried increasing the amount of RAM allocated to Burp? (50% is used by default - defined in the VMOPTIONS file in the installation directory) It looks like this could be environmental if it is consistent across multiple versions of Burp.

Jonathan | Last updated: Nov 05, 2020 06:19PM UTC

Thanks for getting back to me! When we use burp, we do not have any other resource intensive apps open. Usually just the browser + burp. We tried firefox, chrome(which is even worse for this problem. Its almost instantaneous), chromium. I will try and get back here with steps as to what we were doing when the freezes happen. Ill ask my colleagues to do the same. How can i run and pull diagnostics for you? I have tried 4 CPU cores, and 2 CPU cores for my VMs. When you mean platform installer do you mean launching the app using the actual shortcut vs calling burp from the cli with java -jar? I have not tried with the cli caller. i will do that. Ill try allocating more and less ram than the default so i can see what the difference is if any. Hope to get back to you soon!

Uthman, PortSwigger Agent | Last updated: Nov 06, 2020 09:53AM UTC

Thanks a lot. You can get the diagnostics from Help > Diagnostics or by using the --diagnostics command line parameter. Is there a specific event causing the lockup? Are you viewing a large response in the Repeater? Launching multiple intruder attacks at the same time? By platform installer, I am referring to e.g. the .exe for Windows.

You need to Log in to post a reply. Or register here, for free.