Burp Suite User Forum

Login to post

Burp pre-configured browser not working

Marcel | Last updated: Mar 15, 2023 12:31AM UTC

Hi, im currently on a fresh install on kali (Pro Edition). Ive been using burp for years now without problems. However in cant launch the inbuilt browser from the Proxy tab. Just nothing happens, no error, no browser window. I checked processes, nothing starts. Help > Health check for Burps Browser says "All checks completed successfully". With Diagnostics i found the browser directory and tried running the chrome executable manually, works aswell, no errors. I tried disabling all extensions and re-installed twice now. I also re-installed chromium and google-chrome (dont think that matters at all). Current user owns Burps install dir and all children. Running Burp as root doesnt help either. Im really puzzled as i dont even get an error Help is appreciated!

Michelle, PortSwigger Agent | Last updated: Mar 15, 2023 10:23AM UTC

Thanks for getting in touch. Which version of Burp are you using? Can you please email a copy of the output from Help -> Diagnostics for your installation to support@portswigger.net?

Marcel | Last updated: Mar 15, 2023 08:16PM UTC

Thanks for the reply! Im using the latest version and also tried the previous stable version. I send my diagnostic file per email.

Michelle, PortSwigger Agent | Last updated: Mar 16, 2023 09:23AM UTC

Thanks :) We'll take a look and be in touch soon.

You need to Log in to post a reply. Or register here, for free.