Burp Suite User Forum

Login to post

Burp only on one tab row

olek | Last updated: Oct 25, 2021 07:08PM UTC

Hi if you install to many extension Burp create two row tab and change size.backing to one row you have removed some extension. Some extension change burp size but some not. It is any way or options setting Burp only on one tab row.I try a lot of but I can not change it .I use Jar version.

Hannah, PortSwigger Agent | Last updated: Oct 26, 2021 09:53AM UTC

Hi Creating new tabs that exceed the length of Burp's navigation bar will cause the bar to stack. If you'd like to change this behavior, I'd recommend checking out the "Sharpener" extension on the BApp Store - it has the option to change this behavior to a scrollable panel.

olek | Last updated: Oct 26, 2021 11:15AM UTC

ok Sharpener work but why Burp do not allow my do this ??? only 1 extension SQlipy change my View tabs ??? Why ??? Some extension go Up on tab bar what is good but .Why Burp allow change Size and line .......... this look like this . https://user-images.githubusercontent.com/1798313/136854808-d916f051-effc-483f-a388-b26d5b5f3ff2.png

Hannah, PortSwigger Agent | Last updated: Oct 26, 2021 03:10PM UTC

Burp Extensions are able to add tabs to your installation. This is usually done because they have GUI components that are required to interact with them. When multiple GUI tabs are added to Burp and they exceed the width of the Burp window, Burp will automatically stack them into multiple layers, so you can still view all of your tabs. Using the Sharpener extension you can change this behavior. You can do this by clicking on the Sharpener menu item, then going to "Global options > Scrollable tool pane". There are a lot of other visual settings you can modify with the Sharpener extension - more details can be found in the description and the GitHub repository for the extension: https://github.com/mdsecresearch/BurpSuiteSharpener

olek | Last updated: Oct 26, 2021 07:58PM UTC

ok I understand but """Burp will automatically stack them into multiple layers"" How to force Burp not put multiple layers only 1 line.??? without any Sharpener extension???

Hannah, PortSwigger Agent | Last updated: Oct 27, 2021 09:19AM UTC

This is not currently possible. We have an ongoing feature request to change this behavior, which I've added your +1 to. However, we do not have an estimated timeframe for when this will be implemented.

olek | Last updated: Oct 27, 2021 01:11PM UTC

Hannah please noticed the same situation is in repeater.2 lines and lack Order ...

You need to Log in to post a reply. Or register here, for free.