Burp Suite User Forum

Login to post

BURP not working with IOS 14.4

Akki | Last updated: Feb 04, 2021 11:25PM UTC

upgrade ipad to 14.4 and unable to capture any traffic in burp.unable to download certification in safari or chrome .all setting are checked no problem with any setting.tried with latest burp prof 2020.12.1 and with java 14

Uthman, PortSwigger Agent | Last updated: Feb 05, 2021 10:24AM UTC

Hi Akki, Thanks for reporting this. What errors are you seeing in the Event log? Have you tried disabling TLSv1.3 on your Proxy listener? You can do this by selecting a listener > Edit > TLS Protocols > Use custom protocols.

Akki | Last updated: Feb 06, 2021 09:05PM UTC

tried with disabling TLS 1.3 still the same.

Ben, PortSwigger Agent | Last updated: Feb 08, 2021 11:16AM UTC

Hi, Are you able to send an email to support@portswigger.net with screenshots of your setup (proxy details in your iPad and Burp settings) so that we can investigate this further for you?

azri | Last updated: Jun 11, 2021 10:41AM UTC

Hi, I'm having the same issue here. I already configure the proxy and already follow the steps from https://portswigger.net/support/installing-burp-suites-ca-certificate-in-an-ios-device and https://portswigger.net/support/configuring-an-ios-device-to-work-with-burp. Laptop and iphone is connected to same wifi. Whenever I try to surf http://burp , the browser keep loading and end. I unable to download the Burp Cert. Phone model = iphone 7+ Software version = ios 14.5.1

Ben, PortSwigger Agent | Last updated: Jun 11, 2021 10:56AM UTC

Hi, Can you clarify what happens when you try to browse to the site http://example.com in the browser of your mobile device? I just want to confirm the integrity of the initial connection that you have setup. If you want to send us an email at support@portswigger.net and include some screenshots of what you are seeing so that we can see exactly what is happening then please feel free.

You need to Log in to post a reply. Or register here, for free.