Burp Suite User Forum

Create new post

Burp Not capturing the request even the intercept on

d1pakda5 | Last updated: Jul 18, 2015 01:43AM UTC

Here i want the solution of this issue Burp Not capturing the request even the intercept on and i can see the brup target its capturing but not the intercept even if the scanner also capturing but in intercept tab even its on no request is showing

PortSwigger Agent | Last updated: Jul 20, 2015 07:43AM UTC

In Burp, go to Proxy / HTTP history. Then, in your browser, hit refresh a few times to load the page. If your traffic is going via Burp, then you should see new entries appearing at the end of the Proxy history table as you hit refresh. If that is working and nothing is being intercepted in the Proxy intercept tab, then (a) go to Proxy / Options / Intercept client requests, and click the button near the top left to restore defaults; (b) go to Proxy / Intercept and enure that the interception toggle button says "Intercept is on".

Burp User | Last updated: Oct 02, 2015 10:35PM UTC

It works with (a) to restore defaults. The issue was the URL was checked. The default has URL unchecked. Problem solved. Thanks so much

Burp User | Last updated: Oct 24, 2019 05:42PM UTC

I made a solution to fix the problem . If your Burp Suite cant capture data from Firefox or Waterfox browsers or problem with intercepting data then you can check my tutorial. here is the link:- https://youtu.be/7WC4bhZGIC0

kane | Last updated: Nov 24, 2023 10:52AM UTC

my burpsuite also not working when i intercept a website. it intercepted the website but not showing username and password here it is: GET /tr/?id=283492242055251&ev=SubscribedButtonClick&dl=https%3A%2F%2Fwww.torrid.com%2Faccount%3Fdwcont%3DC1639653689&rl=https%3A%2F%2Fwww.torrid.com%2Faccount%3Fdwcont%3DC1638183896&if=false&ts=1700821955135&cd[buttonFeatures]=%7B%22classList%22%3A%22button%20redBtn%20spc-login-btn%22%2C%22destination%22%3A%22https%3A%2F%2Fwww.torrid.com%2Faccount%3Fdwcont%3DC1639670803%22%2C%22id%22%3A%22%22%2C%22imageUrl%22%3A%22%22%2C%22innerText%22%3A%22SIGN%20IN%22%2C%22numChildButtons%22%3A0%2C%22tag%22%3A%22button%22%2C%22type%22%3A%22submit%22%2C%22name%22%3A%22dwfrm_login_login%22%2C%22value%22%3A%22Sign%20In%22%7D&cd[buttonText]=SIGN%20IN&cd[formFeatures]=%5B%7B%22id%22%3A%22dwfrm_login_username_d0dfdetobgkn%22%2C%22name%22%3A%22dwfrm_login_username_d0dfdetobgkn%22%2C%22tag%22%3A%22input%22%2C%22inputType%22%3A%22email%22%7D%2C%7B%22id%22%3A%22dwfrm_login_password%22%2C%22name%22%3A%22dwfrm_login_password%22%2C%22tag%22%3A%22input%22%2C%22inputType%22%3A%22password%22%7D%2C%7B%22id%22%3A%22dwfrm_login_rememberme%22%2C%22name%22%3A%22dwfrm_login_rememberme%22%2C%22tag%22%3A%22input%22%2C%22inputType%22%3A%22checkbox%22%7D%2C%7B%22id%22%3A%22g-recaptcha-response%22%2C%22name%22%3A%22g-recaptcha-response%22%2C%22tag%22%3A%22textarea%22%7D%2C%7B%22id%22%3A%22%22%2C%22name%22%3A%22dwfrm_login_login%22%2C%22tag%22%3A%22button%22%7D%2C%7B%22id%22%3A%22%22%2C%22name%22%3A%22dwfrm_login_securekey%22%2C%22tag%22%3A%22input%22%2C%22inputType%22%3A%22hidden%22%7D%2C%7B%22id%22%3A%22reCaptcha%22%2C%22name%22%3A%22reCaptcha%22%2C%22tag%22%3A%22input%22%2C%22inputType%22%3A%22hidden%22%2C%22valueMeaning%22%3A%22empty%22%7D%5D&cd[pageFeatures]=%7B%22title%22%3A%22Sites-torrid-Site%22%7D&cd[parameters]=%5B%5D&sw=1280&sh=1024&udff[em]=021c1b4cc96e28842aa4361cba93cd95a9e807123a342bd752be7c250fb59bd8&v=2.9.138&r=stable&a=tmtealium&ec=1&o=6174&fbp=fb.1.1700820107657.2113759931&ler=other&it=1700821874491&coo=false&es=automatic&tm=3&rqm=GET HTTP/2 Host: www.facebook.com Sec-Ch-Ua: "Chromium";v="119", "Not?A_Brand";v="24" Sec-Ch-Ua-Mobile: ?0 User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/119.0.6045.159 Safari/537.36 Sec-Ch-Ua-Platform: "Linux" Accept: image/avif,image/webp,image/apng,image/svg+xml,image/*,*/*;q=0.8 Sec-Fetch-Site: cross-site Sec-Fetch-Mode: no-cors Sec-Fetch-Dest: image Referer: https://www.torrid.com/ Accept-Encoding: gzip, deflate, br Accept-Language: en-US,en;q=0.9 Priority: u=3, i Im a newbie can anyone help me why it is that and how can i solve this

Dominyque, PortSwigger Agent | Last updated: Nov 24, 2023 11:46AM UTC

Hi Kane Are you using the embedded browser or an external one? Have you tried looking at the requests in the HTTP History and sending them to Repeater?

kane | Last updated: Nov 25, 2023 01:37PM UTC

I'm using embedded browser and yes i checked HTTP History but the login credentials isn't showing anywhere. However i notice one thing whenever i turn on interception my internet doesn't work. why??

Ben, PortSwigger Agent | Last updated: Nov 27, 2023 08:24AM UTC

Hi Kane, How a particular site deals with sending credentials is going to be fairly bespoke to that site - are you sure that you are looking at the correct request (I would assume you would likely be looking for a POST request). Are you able to clarify what you mean by your internet not working when you turn on interception? With the 'Intercept is on' configuration set within Burp, any requests that are sent from your proxied browser will be being stalled within Burp for you to perform some manual action on them (the web page itself will not load unless and until these requests are forwarded to the destination web server) - is this what you are seeing or something else?

You must be an existing, logged-in customer to reply to a thread. Please email us for additional support.