Burp Suite User Forum

Login to post

Burp Fails to add Jython.jar

Denis | Last updated: Jun 25, 2019 09:01AM UTC

I downloaded and installed Jython-2.7.0 following the link provided by Burp. I try to add this one to Burp and facing the error message: java.lang.ClassNotFoundException: burp.BurpExtender at java.base/java.net.URLClassLoader.findClass(URLClassLoader.java:471) at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:588) at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:521) at java.base/java.lang.Class.forName0(Native Method) at java.base/java.lang.Class.forName(Class.java:398) at burp.yy.a(Unknown Source) at burp.yy.<init>(Unknown Source) at burp.df7.a(Unknown Source) at burp.nv.lambda$panelLoaded$0(Unknown Source) at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:515) at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264) at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128) at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628) at java.base/java.lang.Thread.run(Thread.java:834) My configs: Burp - Enterprise Edition 1.0.17beta; java version "12.0.1" 2019-04-16 Java(TM) SE Runtime Environment (build 12.0.1+12) Java HotSpot(TM) 64-Bit Server VM (build 12.0.1+12, mixed mode, sharing) Win 10 - Version 1903, OS Build 18362.30

PortSwigger Agent | Last updated: Jun 25, 2019 09:49AM UTC

It looks like you're trying to add Jython as an extension. Instead, please configure Jython in Extender > Options > Python Environment

Burp User | Last updated: Jun 26, 2019 10:04AM UTC

It helps, thanks. My bad.

akash-hamal | Last updated: Apr 09, 2021 04:56AM UTC

hi team, i am getting same error while loading extensions even after i have loaded jython standalone jar in python environment I am using version 2021.3.1 of burp professional version and i am on macbook air Can you help me figure out whats wrong

akash-hamal | Last updated: Apr 09, 2021 05:11AM UTC

hi sorry for inconvenience i figured out, i just restarted burp and loaded those extensions and it worked :)

Liam, PortSwigger Agent | Last updated: Apr 09, 2021 05:49AM UTC

Thanks for letting us know.

You need to Log in to post a reply. Or register here, for free.