Burp Suite User Forum

Login to post

burp community-failed to connect to website.com:443

Walid | Last updated: Jan 14, 2021 06:50PM UTC

Hi, I'm trying to connect to website using burp chromium browser. But most of the time, the loading end by an error screen saying "failed to connect to website.com:443" I searched but didn't fought any awnser that helped me. Also my proxy listener is 127.0.0.1 with port 8080 and not 433 if it's in relation. I'm on rdp windows. Thanks for you answers

Ben, PortSwigger Agent | Last updated: Jan 15, 2021 08:22AM UTC

Hi, This message is usually indicative of Burp not being able to connect to the destination web server. Do you see this error message for every site that you try to browse to when Burp is running or just certain ones? Do you normally use a LAN proxy to access the internet in your environment?

James | Last updated: Oct 30, 2022 10:12PM UTC

I am having the same issue as this, specifically for labs. Have you found a solution?

Ben, PortSwigger Agent | Last updated: Oct 31, 2022 09:42AM UTC

Hi James, Just to clarify the scenario - are you only seeing this when interacting with the labs and is it only when you come to attempt to launch a lab?

HedOnly | Last updated: Nov 15, 2022 12:49PM UTC

Hi Ben, I am having the same issue, using Burp on Mac. Even using embedded Chromium browser and still getting same error for every site: Error Failed to connect to facebook.com:443 or Error Failed to connect to google.com:443 ..and yes, using LAN proxy for accessing internet. Could you help me with this? Thank you!

HedOnly | Last updated: Nov 15, 2022 01:35PM UTC

Well I am not sure which one really helped but I will try to explain how I solved this issue (that I asked above) Firstly I added certificate of my local proxy to burp as it is shown here: https://www.ibm.com/docs/en/tnpm/1.4.2?topic=security-import-certificate-jre-keystore Secondly I defined an upstream proxy in burp (User options > Upstream Proxy Servers) by defining a rule with (host: *, ip: <ip of local proxy>, port: <port of local proxy>). ..and it solved the problem for me, hope it helps you too!

Ben, PortSwigger Agent | Last updated: Nov 16, 2022 08:08AM UTC

Hi, Glad to hear that you were able to resolve the issue - your solutions makes sense. By default, Burp will try to make direct requests to the destination web server - if you have some kind of proxy in place in your environment you would need to configure this under the Upstream Proxy Server settings within Burp so that Burp will then issue requests via this proxy. Depending upon the type of proxy in place you might, as was the case in your situation, need to add the corresponding certificate to the Java trust store that is being used.

You need to Log in to post a reply. Or register here, for free.