Burp community forum

Burp Collaborator

Sharon | Last updated: Jul 10, 2019 12:23PM UTC

Hello, I'm trying to setup a private burp collaborator server the only things I have: Kali machine in a VM and burp No internet connection, just a single machine to work with how can I setup the collaborator in this way ? (I've tried multiple threads on the net as well as portswigger's guide but nothing fit to my needs) any suggestions please (btw, I don't need a certificate),

Liam, PortSwigger Agent | Last updated: Jul 10, 2019 01:40PM UTC

Sharon, have you checked out or online docs for configuring a private collaborator server on a closed network? You need to configure Burp to use your machine's IP address as its Collaborator server: - https://portswigger.net/burp/documentation/collaborator/deploying#basic-set-up-on-a-closed-network Please let us know if you need any further assistance.

Burp User | Last updated: Jul 11, 2019 01:13PM UTC

this is the syntax as described at the guide, https://imgur.com/a/uhMxdtN Further, the burp doesn't open after submitting the syntax above just the splash screen pops and disappears *Note - all the files are in the same folder Thanks, Sharon

Burp User | Last updated: Jul 11, 2019 01:48PM UTC

Moreover, the following is the configuration file & the syntax with a specification to the configuration file leads to error: https://imgur.com/yVYyrPH https://imgur.com/w0srjUi

Burp User | Last updated: Jul 11, 2019 02:37PM UTC

To be more clear, I want to use Kali VM as a collaborator server and my host machine (windows) will sync with Kali VM collaborator Thanks, Sharon

Burp User | Last updated: Jul 11, 2019 02:50PM UTC

This is the health check from my host: (I've configured the hosts file the IP address of kali to the DNS name of it) https://imgur.com/5tSnZDG

Rose, PortSwigger Agent | Last updated: Jul 15, 2019 08:02AM UTC

Sharon, the setting in Project options > Misc > Burp Collaborator Server > Use a private Collaborator server > Server location should be the IP address/localhost depending on your set-up. You can't configure DNS for a private collaborator on a closed system, so you'll need to remove all that configuration. If you run the health check, it may warn you about this but it should still start up. When you run Burp in Collaborator server mode, it won't start up Burp. It starts up a Collaborator server that runs in the background. You will then need to start up a copy of Burp normally. Please let us know if you need any further assistance.

Burp User | Last updated: Jul 18, 2019 08:49AM UTC

Hi Rose, Thanks a bunch!!, it seems to be working now (I've removed the previous settings) :D, How can I configure the DNS to work ? I've setup the collaborator server to my Kali's IP address instead of the DNS name of it (I receive an error when trying to setup the DNS) This is the current health check: https://imgur.com/Kd4RVo3

Liam, PortSwigger Agent | Last updated: Jul 19, 2019 09:03AM UTC

Hi Sharon As your running this on a closed network, DNS isn't going to work. Please let us know if you need any further assistance.

Burp User | Last updated: Jul 24, 2019 09:00AM UTC

Can I configure the HOSTS file or the resolv.conf to make it work ?

Liam, PortSwigger Agent | Last updated: Jul 24, 2019 12:59PM UTC

No, that won't work. DNS won't work on a closed network. Please let us know if you need any further assistance.

You need to Log in to post a reply. Or register here, for free.