Burp Suite User Forum

Login to post

Burp certificate ans Kaspersky

Romain | Last updated: Jul 05, 2021 12:43AM UTC

Hi, When I install the Burp certificate and configure the proxy properly with Firefox, Kaspersky prevent me from loading web pages. It tells that the website cannot be trusted due to the PortSwigger CA certificate. Can you help me?

Michelle, PortSwigger Agent | Last updated: Jul 05, 2021 02:02PM UTC

Thanks for your message. Do you see the same error if you use Burp's embedded browser? Do you see the same issue if you use Burp on a different machine or a virtual machine? If Kaspersky is preventing you from loading the web pages, you may need to check if there are any options within Kaspersky that allow you to tell Kaspersky to trust Burp's certificate or whether you can add an exception for this connection to Kaspersky. I hope this helps. Please let us know if you need any further assistance.

Hashim | Last updated: Aug 06, 2022 11:47AM UTC

I followed those steps on their official website and it worked, https://support.kaspersky.com/common/safemoney/12489

Hashim | Last updated: Aug 06, 2022 11:50AM UTC

1-In the main window of your Kaspersky application, click The settings icon in the lower-left corner of the window 2-In the settings window, go to the Network settings section and select Manage exclusions. 3-Click Add. 4-Specify the website address that was displayed in the certificate warning message. Select the Active status and click Add (portswigger.net) 5-Click Save. 6-Click Yes.

You need to Log in to post a reply. Or register here, for free.