Burp Suite User Forum

Login to post

Automatic Backup Fail

Yoan | Last updated: Dec 10, 2019 04:17PM UTC

My automatic backup fails every time with this error message : "Failed to rename backup file"

Ben, PortSwigger Agent | Last updated: Dec 10, 2019 04:27PM UTC

Hi, Can you confirm the version of Burp that you are using? Are you trying to backup the project file to a standard drive location or on a shared drive?

Mark | Last updated: Mar 19, 2022 04:37AM UTC

I have the same issue...running 2022.2.3 early adopter. I'm saving to a local hard drive location. "Error performing backup: failed to rename backup file". Thanks!

Ben, PortSwigger Agent | Last updated: Mar 21, 2022 02:09PM UTC

Hi Mark, Has the saving of backup files previously worked for you and this is a new issue or have you been having this issue for a period of time? Do you have any anti-virus software or anything that could potentially be affecting the process of Burp saving the file? Do you already have User Options -> Misc -> Submit anonymous feedback enabled? If yes, can you please send me your debug ID (if you would prefer to do this via email then please feel free to send us an email at support@portswigger.net).

Paulius | Last updated: May 12, 2022 07:06AM UTC

I have exactly the same issue which lasts for over a year now, so all versions since 2020 were tried and all them have same issue. Saving on local drive, permissions are fine and the issue usually happens when the files grow larger (after scan of multiple apps).

Ben, PortSwigger Agent | Last updated: May 12, 2022 05:41PM UTC

Hi Paulius, Are you able to send us an email to support@portswigger.net and include your diagnostic information (this is available via the Help -> Diagnostics main menu option from within Burp)? Would you also be able to provide some details regarding the size of the project files and the types of activities that were performed within the project itself? We have recently identified and fixed an issue with saving Intruder attacks that could cause possible project file corruption so it would be useful to know if this is a possible cause of what you are seeing (this has been fixed in the recent 2022.3.7 release).

You need to Log in to post a reply. Or register here, for free.