Burp Suite User Forum

Any access with proxy

Andy | Last updated: Nov 21, 2019 01:57PM UTC

Hello, the proxy doesn't work on any computer for me. I have followed the instructions given on your site (burp, browser and certificate configuration). I tried using it on a Mojave Mac OS, Windows 8.1 and Debian 18.04 systems. I tried it with the Firefox, Chrome, Safari and Opera browsers, but still to no avail. I can't access any site (http or https) when the interception is on. Could you help me, please, to solve this problem?

Ben, PortSwigger Agent | Last updated: Nov 21, 2019 02:13PM UTC

Hi Andy, When you say that you have interception on, do you mean that you have the Intercept is on setting configured under Proxy -> Intercept within Burp? If so, this will mean that Burp will intercept any requests made from your browser and will be waiting for your manual intervention before forwarding the request onto the web server. You would need to switch this setting to Intercept is off in order to be able to browse normally (the requests still go through Burp but will not require you to perform any manual actions to forward them to their destination).

Burp User | Last updated: Nov 26, 2019 01:34PM UTC

Thank you, indeed, when I disable the interception I access all the sites. However, in the "Event log" section of the Dashboard I have several error messages like "The client failed to negotiate an SSL connection to aus5.mozilla.org:443: Received fatal alert: bad_certificate", is that normal?

Michelle, PortSwigger Agent | Last updated: Nov 26, 2019 01:36PM UTC

Hi Andy Thanks for the update. It's possible the browser is not trusting the Burp certificate. I think you may have already seen these, but these articles should help you double-check everything's in place - https://support.portswigger.net/customer/portal/articles/1783118-getting-started-with-burp-proxy - https://support.portswigger.net/customer/portal/articles/1783119-using-burp-proxy If everything looks to be ok you could try deleting it, regenerating it and re-importing it to your browser. If you are still having problems, could you send us a screenshot of your CA authorities tab, please?

Burp User | Last updated: Dec 09, 2019 09:11AM UTC

Hello, I did all the manipulations as explained in the videos, but I still have many errors in the proxy. How could I send you screen shots? I don't see any possibility to add images to this discussion. Thank you very much.

Ben, PortSwigger Agent | Last updated: Dec 09, 2019 09:15AM UTC

Hi Andy, If you require further assistance please send an email to support@portswigger.net. You can then include screenshots etc that will help us diagnose your issue.

You need to Log in to post a reply. Or register here, for free.