Burp Suite User Forum

Create new post


Steven | Last updated: Sep 18, 2018 08:13PM UTC

Using Burp Suite CE 1.7.36. Pointing my Android Emulator to use the Burp Proxy running on my localhost. I get the following errors in both Chrome and the Android System WebView. I get them inconsistently, but regularly, while connecting to my company website and application. Failed to load resource: net::ERR_SSL_PROTOCOL_ERROR If I remove Burp from the equation, and point directly at the site in question, then it connects without issue. All certs appear to be valid, and I have trusted the BURP CA on the emulator devices. When burp is in proxying, then I get the SSL PROTOCOL errors. This seems to happen much more frequently on the newer Android Emulator images (v25, v26+). Are there any settings I can adjust? Any ideas are greatly appreciated.

Liam, PortSwigger Agent | Last updated: Sep 19, 2018 07:34AM UTC

Since Android Nougat, Android no longer trusts user or admin supplied CA certificates. We recommend that you use an older version of Android for your testing. Which version of Android is your emulator? If you must use Android Nougat onward then you will need to install a trusted CA at the Android OS level on a rooted device or emulator. Please let us know if you need any further assistance.

You must be an existing, logged-in customer to reply to a thread. Please email us for additional support.