Burp Suite User Forum

A Message When Burp cannot Listen to Address and Port

Les | Last updated: Feb 28, 2020 07:17PM UTC

I ran into this a few times, and figure it out each time, but a message would be nice. Description: When Burp Suite (Community) starts up, and is configured to listen to 127.0.0.1:8080, but that port is unavailable (in use by another program or service), then Burp (appropriately) does not capture or intercept any traffic. But the user has very little to indicate why their expectation of traffic being capture (also a reasonable expectation) is not fulfilled. Their only indications are, 1) No traffic in any of the panes, 2) on the Proxy Tab, on its Opotions Tab, under Proxy Listeners, the checkbox under "Running" is un-checked. Feature Requested: A "banner" message or pop-up message to indicate that the chosen listener configuration is not operating, and (if it can be detected) the reason why, like the address is already in use. Rationale: I am often experimenting with programs and services. Some services like to choose address "0.0.0.0" and when it binds port 8080, it grabs loop back traffic, too. I end up diagnosing and fixing this often. I'm getting faster, but it's not often enough to remember right away how I fixed it before. Not a high severity feature, more like a nice to have.

Ben, PortSwigger Agent | Last updated: Mar 02, 2020 01:17PM UTC

Hi Les, Just to clarify your request, you would want some kind of message to be displayed if the assigned listener port is not available when Burp is started in order to inform the user that the proxy listener is not running? Cheers Ben Wright Technical Product Specialist PortSwigger Web Security

You need to Log in to post a reply. Or register here, for free.