Burp Suite User Forum

Login to post

Burp Carbonator does not work for me

Rohil | Last updated: Sep 21, 2017 06:47PM UTC

I am trying to play around with the carbonator feature of Burp using the demo.testfire application as a test run and had a few questions and issues. Issues: I have installed carbonator and using the command " java -jar <path to burp> http://demo.testfire.net/bank/login.aspx 80". However, this just opens the Burp instance and does not do anything. Is there anything that I am missing out on? Questions: Does Carbonator do an authenticated scan? If yes, how?

PortSwigger Agent | Last updated: Sep 22, 2017 03:35PM UTC

Hi Rohil, The Cabonator command line is slightly different to what you've used. Try this: java -jar path/to/burp.jar http demo.testfire.net 80 /bank/login.aspx If that doesn't work, go to Extender > Extensions > Carbonator > Errors - you may get an error message explaining what's wrong. For authenticated scans, first configure Spider with credentials and confirm that Spider is logging in correctly. The relevant area is Spider > Options > Application login. Then click the cog icon next to Application Login, choose Save options and select "auth". You can then start Burp like this: java -jar path/to/burp.jar--config-file=auth.json http demo.testfire.net 80 /bank/login.aspx It may take some experimentation, but you can get authenticated Carbonator scans working this way.

Burp User | Last updated: Sep 26, 2018 10:48PM UTC

I wanted to try scan a web app using Carbonator+Burp. So I first attempted configuring the credentials in the spider like suggested above and then checking that Burp was able to spider correctly using the credentials. But it does not seem to. Here is how I attempted it: Launched Burp, went to spider and entered id/password in Spider->Options->Application Login. Saved them to a file - it did get saved to auth.json. Went to Proxy and turned Intercept to Off. Adjusted proxy setting in browser and then browsed to the application URL. Got presented with a login screen. I did not enter credentials as I wanted to check that Burp spider is able to login using that I supplied. Switched back to Burp and in Target->Sitemap saw the application URL show up. I added it to scope. Then right click the application url in Target->Sitemap->Spider this host. Checked in the Spider tab that the spider was not running (has finished). However looking at the url it found in the Sitemap it clearly was unable to get past the login. Is this supposed to work? Note: If I login to the application from the browser and launch spider after it then it seems to gather a couple of URLs but then it is just using the session that was established from browser.

PortSwigger Agent | Last updated: Sep 27, 2018 08:19AM UTC

Hi Ajay, What version of Burp are you using. The authentication support in Burp 1 is quite basic and fails on quite a lot of applications. However, this is greatly improved in the Burp 2 beta. If you move to the Burp 2, you're probably best not using Carbonator and instead using the native REST API to launch a scan. If Burp 2 fails to login it would be really helpful if you could share the HTML source for the login page.

Burp User | Last updated: Sep 27, 2018 03:32PM UTC

I am using Burp Pro 1.7.37. I will try to checkout Burp 2 Beta. Where can I find documentation on the REST API and its usage? thanks

Burp User | Last updated: Sep 27, 2018 06:37PM UTC

One more question: Does this issue with authentication Burp 1.x also exist in the Enterprise edition? And/or does the latest version of Enterprise edition have a better authentication support like 2.x Pro beta. thanks

PortSwigger Agent | Last updated: Sep 28, 2018 07:06AM UTC

Hi Ajay, There's documentation on the REST API if you visit the service with a browser. Look in User options > Misc > REST API and enable the service. If you visit with a browser, there's an interactive request builder, and you can get an OpenAPI spec. Burp Enterprise uses Burp 2 internally so it has the improved authentication support. Please let us know if you need any further assistance.

Burp User | Last updated: Dec 03, 2019 11:06AM UTC

the crawler is showing only few location even if provided with the correct credentials

Ben, PortSwigger Agent | Last updated: Dec 03, 2019 11:10AM UTC

Hi Aditya, Are you able to provide some more details of the site that you are trying to crawl and the issues that you are encountering?

You need to Log in to post a reply. Or register here, for free.